This is document of tariff plan samples

Version: Tariff Plan Samples V1.0
Generation time: Sat Jun 25 09:20:00 2005


Tariff sample

[Next]

Sample for USA


Tamplate

[Next]

Sample for USA

Step 1


Tamplate

Sample for USA

Step 2


Tamplate

Sample for USA

Step 3


Tamplate

Sample for USA

Step 4


Tamplate

Sample for USA

Step 5


Tamplate

Sample for USA

Step 6


Tamplate

Sample for USA

Step 7


Tamplate

[Previous]

Sample for USA

Step 8


Tariff sample

Sample for Zambia


Tariff sample

Sample for Albania


  1. Tariff plan for your country
  2. Your local plan


  1. Number Length element. This element is used to filter out calls which dialed number length doesn't match the element bounds. This restriction is added for optimization purposes and to filter out e.g. internal calls starting with 00


  1. Access Code element. This element is used instead of Number/Prefix element in cases when in addition to numbers filtering it is necessary to do numbers parsing. When the system sees Access Code element with 00 value, it at first checks if current number matches the 00 prefix and at second performs region search in regions lookup table against current number with 00 prefix removed from it. Thus, that means that all numbers starting with 00 will pass through this element and some region will be associated to every number here.
  2. Number/Prefix element is used to filter calls on their numbers.


  1. Rate element is used for call cost calculation. All calls passed here will be rated according the Rate element.


  1. Call Type section is used to filter calls by a call direction (e.g. to filter only outgoing calls).
  2. Rate element for Connaction Fee. This element is used to define connection fee, which will be added to final cost.


  1. Transparent Code element assigns a region to every call passed throug it.
  2. Expand region element is used to find region by call`s number which starts from current prefix. You need to use it when code of your country is the same with some other country. e.g.: USA and Canada have the same code "1".


  1. Time Slot element is used to filter calls by time, day of week and holidays.


In the sample for USA you can see following:
  1. Number Length is between 9 and 40. It means that current tariff plan will work with calls which have number length between 9 and 40.
  2. For determine IDD calls we are using Access Code element with prefix 011. It means that all calls which have 011 at the beginning of their numbers are IDD calls
  3. Call Type is Outgoing. It means that next elements will work only with outgoing calls
  4. Under Call Type element you can see two Rate elements. The first element define rate for IDD calls. This rate is 1.5 units per 60 seconds and rating starts from 0 second
    The second Rate element defines Connection fee which is 0.1 units
  5. Number Prefix with prefix 1 means that this is section for calls which have 1 at the beginning of their numbers. The next element in this section is Expand Region element. We use it to define calls to regions which have code 1, because USA also has code 1. So in this case 1 is not just a prefix, it is a part of region`s code, e.g.: Canada have code 1, so if dialed number is 1403XXXXXXX then in result we will see that this call was dialed to Calgary (CANADA\Alberta).
  6. Also you can see Number prefix element which has value *. It means that this section will work with all calls which have no 011 and 1 at the beginning of their numbers. This is section for NDD calls. And Transparent code element which have value UNITED STATES OF AMERICA will determine regions inside USA region
  7. In this sample you can see Time Slot elements. There are two types of Time Slot element in the sample. The First type is used for a calls which was dialed from 00:00 to 24:00 from Monday to Friday. The second type is used for calls which was dialed from 00:00 to 24:00 on Sunday, Saturday and on Holidays
  8. Under Time Slot elements you can see Rate elements. These elements work as Rate element of Access Code section. Here is only one difference in value of units.
  9. Under Default tariff plan for USA you can see section for Local call. This section contains Number Length element which have value between 1 and 8. It means that all calls with number length less than 9 will be processed in this section and tariff will be used from Rate element under this Number Length element.


In the sample for Albania you can see following:
  1. Number Length has a value between 4 and 40. It means that this section will work with calls which have number length between 4 and 40.
  2. Call Type is Outgoing. It means that next elements will work only with outgoing calls
  3. For determine IDD calls we are using Access Code element with prefix 00. It means that all calls which have 00 at the beginning of their numbers are IDD calls
  4. Call Type is Outgoing. It means that next elements will work only with outgoing calls
  5. Inside Access code element you can see the list of Group elements. It is used to group countries by several zones. And each Group element have list of corresponding regions and Time Slot elements which are define different Rate elements for different time
    Please note that Canada and USA have same code 1. So we have inserted sublist of regions inside Canada and USA. These are regions of Canada and USA which have not only 1 in their codes, e.g.: Calgary (CANADA\Alberta) have code 1403
  6. Number Prefix with empty prefix means that this is section for calls which have no prefix at the beginning of their numbers. It is section for calls inside city so here we have only Call Type element to filter outgoing calls and Rate element to calculating cost of calls.
  7. Number Prefix with prefix 0 means that this is section for calls which have 0 at the beginning of their numbers. This section for NDD calls. So next we use Transparent Code element with value ALBANIA. Under this element we use Call Type element, which contains Rate element and list of regions. Near Call Type element you can see Region element with value Rural Operators. And inside this element you can see Transparent Code element which determine region from Rural Operators. Then Rate element and Transparent Code element to determine region from Albania. The cause of this construction is in following: In albania we have many operators and for call through other operator people use code of operator. So at first we determine that it was NDD call then we determine code of operator and then we determine region and corresponding rate.
  8. Number Prefix with prefix 06 means that this is section for calls which have 06 at the beginning of their numbers. This section for Mobile calls. Inside this section you can see list of region elements which are mobile operators. And Time Slot elements which contain Rate of Connection fee and usual rate which is different for each Time Slot element.
  9. Under Default tariff plan for Albania you can see section for Local call. This section contains Number Length element which have value between 1 and 3. It means that all calls with number length less than 4 will be processed in this section
  10. Under Number Length element you can see Time Slot elements and each of them have two Rate elements which determine rates for two parts of call. e.g.: first 180 second costs 1.5 units and all other 180 second costs 3 units.


In the sample for Zambia you can see following:
  1. First Number Length is between 6 and 8. It means that this is section for calls which have number length between 6 and 8.
  2. Call Type elements have value Outgoing. So we will work only with outgoing calls.
  3. We have two types of regions. For first type of regions calls have no prefix at the beginning of their numbers. Then we use for these calls Number Prefix element with empty prefix. Then we use Transparent element. This element contains list of regions of first type of regions. Each region have own Rate element with own tariff and interval. All rates start from 0.
  4. For second type of regions calls have prefix 0 at the beginning of their numbers. In this case we use Number Prefix element which have value 0. All next elements are using like in previous section
  5. Next section is Number Length. It has a value between 9 and 40. It means that this section will work with calls which have number length between 9 and 40.
  6. Call Type is Outgoing. It means that next elements will work only with outgoing calls
  7. For determine IDD calls we are using Access Code element with prefix 00. It means that all calls which have 00 at the beginning of their numbers are IDD calls
  8. Inside Access code element you can see list of Region elements. It is list of countries. And each region element have own Rate element.
    Please note that Canada and USA have same code 1. So we have inserted sublist of regions inside Canada and USA. These are regions of Canada and USA which have not only 1 in their codes, e.g.: Calgary (CANADA\Alberta) have code 1403
  9. Number Prefix with prefix 0 means that this is section for calls which have 0 at the beginning of their numbers. Then you can see list of list of region elements which are list of mobile operators. Each Region element have own Rate element.
  10. Under Default tariff plan for Zambia you can see section for Local call. This section contains Number Length element which have value between 1 and 5. It means that all calls with number length less than 6 will be processed in this section
  11. Under Number Length element you can see Rate element and Number Prefix element with list of region elements and Rate element for these regions. So calls for regions from list will use second Rate element which is placed on same level with Region elements. And all other calls will use first Rate element and will be free.