forum => Call Accounting Mate Q&A => Topic started by: smhfc on March 09, 2009, 01:26:51 PM

Title: CAM sooooo slow
Post by: smhfc on March 09, 2009, 01:26:51 PM
I'm been using CAM for some time now. I need to purge the call database every few months or so for speed purposes. This has worked fine until now. Recently I have noticed a dramatic slow down. Last month I purged the database 3 times and checked for old data I may be missing. I only have calls from October 2008 on. 5 months currently. The system is so slow I can't even log-in never mind run reports. A couple of weeks ago after the 3rd back to back purge and no improvment over a weeks time , I cleaned and performed maintenance on the "dedicated" server and re-booted hoping that would help. It did for about a week or two. System again is still so slow it takes about an hour to loggin. Even to purge the calls takes me all day. I get frustrated and walk away. About an hour to get the calendar to open to insert begin date to purge. Then another to enter the end date. Last time I let it purge overnight and it had finally finished by morning. Ridiculous.

Any suggestions?    ::)   :'(
Title: Re: CAM sooooo slow
Post by: Administrator on September 10, 2009, 10:03:45 AM
Are  you purging the Raw data when you purge the calls.  CAM keeps a copy of the raw data as well as the calls data. Please purge the Raw data as well. Alternatively you can clear all the Raw data using the Clear System option on the Maintenance menu. Please note if you clear the raw data you will not be able to reparse your data. We recommend you make a back-up copy of the c:\bill\calls.dat file prior to clearing the raw data. This will allow you to recover the raw data if any issues occur.
Title: Re: CAM sooooo slow
Post by: smhfc on September 11, 2009, 02:25:03 PM
Yes, I purge the raw data too. I've resolved to purging once a month and it seemed to be quicker logging in and to enter the purge dates but takes a long time to purge - hours; and this month I got this error trying to purge twice"Indexed columns are not unique". It  takes me hours to purge and now I'm not even sure if it's actually purging. I haven't had the time to try it again. Do you know what is causing this message and how to speed it up?