Author Topic: Extension Number Changed by CAM ???  (Read 4070 times)

grobert

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
    • View Profile
    • Email
Extension Number Changed by CAM ???
« on: May 12, 2008, 04:54:53 PM »
I sold CAM to a customer over a year ago and they today contacted me regarding new users they have set up recently not showing up in reports.  I did somew testing and determined that when I place a call to extention 417 the call is assigtned to extension 420. 

The SMDR RAW data shpws extension 417:
05/12/2008 05:10:31PM 05.12.08;17:10:30;5;417;00:02;00:00:10;16014378885;;1;;;;;50;;; + 192.168.1.11

The processed call shows extension 420, as follows:
05/12/2008 05:10:30PM 5 Jessica Peragine/420 00:00:10 UNITED STATES OF AMERICA 16014378885 0.01 I 192.168.1.11

This is happening with several extensions added in the last several months.  Both Extensions are in the same department.

The driver is "SIEMENS HIPATH 3000", dated 17 Oct, 2005.  The system is licensed for 250 users and there are only about 140 configured.

grobert

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
    • View Profile
    • Email
Re: Extension Number Changed by CAM ???
« Reply #1 on: June 03, 2008, 03:13:50 PM »
 :)  Answering my own question.  After extensive experimentation, it appears this behaviour ensues when a new extension is entered AND the extension user's name includes a hyphen.  The issue has been fixed by removing the hyphens from all user names.

Suggestions for CAM:

Mention this in the system documentation, and/or
Provide an error message when a user name is entered with a hyphen, or
Correct the system software so that a user can be entered with a hyphenated name and behavior is normal.