Author Topic: database seems corrupted  (Read 3079 times)

Thierry

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
    • View Profile
database seems corrupted
« on: October 21, 2008, 03:39:10 PM »
Hello,

We are no longer able to access the CAM web UI. The service does not seem responsive & bill.exe CPU usage is at 99%.

After looking at the billog.txt, we found out that the database seems to be corruped : Here's the log :

10/21/08 15:54:30   Starting...
10/21/08 15:54:30   2.6.1.97.6
10/21/08 15:54:30   Global\{270653-4249-A1A5-18ED0AF938FF}
10/21/08 15:54:30   SMDR library has been loaded successfully.
10/21/08 15:54:31   HTTP engine has been started.
10/21/08 15:54:31   Requested driver settings:
10/21/08 15:54:31   id = 1;pbxid = 1;pbxname = SUP-COLO-IPOffice;pbxdesc = ;drivername = Avaya (IP Office).js;driverrootpath = SMDR;driveriddthreshold = 8;driverdurcor = 0;commport = TCP;commbaud = 9000;commdatabits = 8;commparity = 0;commstopbits = 10;commdtrdsr = ;commrtscts = ;commxonxoff = ;exprops = ;isdeleted = ;commrowlimit = ;
10/21/08 15:54:31   commport = TCP
10/21/08 15:54:31   commbaud = 9000
10/21/08 15:54:31   commrowlimit = 13,10
10/21/08 15:54:31   drivername = Avaya (IP Office).js
10/21/08 15:54:31   driverrootpath = SMDR
10/21/08 15:54:31   pbxid = 1
10/21/08 15:54:31   driverdurcor = 0
10/21/08 15:54:31   Communication thread for TCP has been started.
10/21/08 15:54:31   TTYINFO {bByteSize:0;bFlowCtrl:0;bParity:0;bStopBits:0;dwBaudRate:9000;fConnected:1;fXonXoff:0;}
10/21/08 15:54:31   DCB {BaudRate:0;ByteSize:0;DCBlength:28;EofChar:0;ErrorChar:0;EvtChar:0;fAbortOnError:0;fBinary:0;fDsrSensitivity:0;fDtrControl:0;fDummy2:0;fErrorChar:0;fInX:0;fNull:0;fOutX:0;fOutxCtsFlow:0;fOutxDsrFlow:0;fParity:0;fRtsControl:0;fTXContinueOnXoff:0;Parity:0;StopBits:0;wReserved:0;wReserved1:0;XoffChar:0;XoffLim:0;XonChar:0;XonLim:0;}
10/21/08 15:54:31   Database has been initialized successfully.
10/21/08 15:54:31   Port 1733 has been opened successfully
10/21/08 15:54:31   Web service has been started successfully.
10/21/08 15:54:31   Intialization has been done.
10/21/08 15:54:31   Le fichier spécifié est introuvable.

10/21/08 15:55:17   malformed database schema - no such table: calls.users in attach database 'q' as calls
10/21/08 15:55:17   no such table: g1 in select * from g1
10/21/08 15:59:07   Driver library global.jsl[V.3.2] loaded.
10/21/08 15:59:07   Loading settings from PBX1 ...
10/21/08 15:59:07   Avaya (IP Office) [V.1.2] driver loaded for PBX#1-TCP.
10/21/08 15:59:07   Current settings=' Capture internal calls:Enabled'
10/21/08 15:59:07   Call parsing failed for call below:
10/21/08 15:59:07   
10/21/08 15:59:07   2008/10/21 15:42:17,00:14:46,11,0148796063,I,201,6150,,0,1004732,0,E309,BC,T9001,Line 1.1,0,0
10/21/08 16:28:15   database is locked in insert into raw_calls(ID, Data, CreationDate, PBXID, PBXIndex, DriverName, CommPort) values(%d, '%q', CurDate(), '%q', '%q',
10/21/08 16:28:15   Call parsing failed for call below:


We tried to analyze & open the database using sqllite tools, but with no success.

Any idea to repair the database & having CAM restarting ???

Thanks.